// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)--rose-([a-z\-0-9]*):(\s)(.*);").unwrap();
let string = "--rose-primary-text: hsl(0, 0%, 0%);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}