re = /--rose-([a-z\-0-9]*):(\s)(.*);/m
str = '--rose-primary-text: hsl(0, 0%, 0%);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end