$re = '/--rose-([a-z\-0-9]*):(\s)(.*);/m';
$str = '--rose-primary-text: hsl(0, 0%, 0%);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);