const regex = /--rose-([a-z\-0-9]*):(\s)(.*);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('--rose-([a-z\\-0-9]*):(\\s)(.*);', 'gm')
const str = `--rose-primary-text: hsl(0, 0%, 0%);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}