# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(cuda)(:\d+)?$"
test_str = ("cuda\n"
"cuda:0\n"
"cuda:1\n"
"cuda:2\n"
"cuda:12\n"
"cuda:999\n"
"cuda:99999\n"
"cuda:\n"
"cuda:-1\n"
"1:cuda:12\n"
"cuda:tuda\n"
"cpu\n"
"acuda:1\n"
"cud")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.