$re = '/^(cuda)(:\d+)?$/m';
$str = 'cuda
cuda:0
cuda:1
cuda:2
cuda:12
cuda:999
cuda:99999
cuda:
cuda:-1
1:cuda:12
cuda:tuda
cpu
acuda:1
cud';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);