use strict;
my $str = 'cuda
cuda:0
cuda:1
cuda:2
cuda:12
cuda:999
cuda:99999
cuda:
cuda:-1
1:cuda:12
cuda:tuda
cpu
acuda:1
cud';
my $regex = qr/^(cuda)(:\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}