$re = '/^([0-1][0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])$/m';
$str = '05:10:36
23:59:59
00:00:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);