# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d\d-\d\d-\d\d\d\d_\d\d:\d\d:\d\d\.\d\d\d).*?tcp:\/\/(\d\d*?\.\d\d*?\.\d\d*?\.\d\d*?):93\?.*?i=(\d).*?tcp:\/\/(\d\d*?\.\d\d*?\.\d\d*?\.\d\d*?):93\?.*?i=(\d).*"
test_str = ("06-20-2023_16:29:30.290 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:29:30.302 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:35:00.424 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:35:00.437 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:48:00.284 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:48:00.301 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:49:57.435 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:49:57.451 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:59:00.290 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_16:59:00.306 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:00:00.213 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=2&t=aaudio\"\n"
"06-20-2023_17:00:00.527 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:00:00.539 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:06:00.287 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:06:00.305 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:06:30.723 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:06:30.734 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:18:00.307 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:18:00.325 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:20:00.942 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:20:00.954 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:29:30.282 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:29:30.291 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:31:42.974 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:31:42.985 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:48:00.276 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:48:00.285 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:49:59.601 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:49:59.612 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:59:00.292 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_17:59:00.305 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_18:59:00.231 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=2&t=aaudio\"\n"
"06-20-2023_18:59:06.422 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:00:00.458 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.20:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:00:00.481 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.20:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:00:56.650 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:00:56.671 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:01:56.113 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=3&t=aaudio\"\n"
"06-20-2023_19:01:56.138 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:02:52.526 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.20:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_19:03:46.493 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=3&t=aaudio\"\n"
"06-20-2023_21:00:00.220 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.20:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_21:01:58.907 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=3&t=aaudio\"\n"
"06-20-2023_21:02:10.382 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.20:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_21:02:10.398 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.20:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_21:02:12.814 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=3&t=aaudio\"\n"
"06-20-2023_21:02:12.830 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.53:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_22:00:00.416 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-20-2023_22:00:00.428 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:00:31.596 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:00:31.614 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:06:00.291 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:06:00.307 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:07:27.597 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:07:27.610 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:19:00.306 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:19:00.320 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:21:02.551 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:21:02.564 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:29:30.271 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:29:30.283 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:30:57.620 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:30:57.636 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:44:00.288 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:44:00.307 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:45:01.557 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:45:01.568 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:49:35.288 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:49:35.304 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:50:35.785 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:50:35.798 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:51:30.332 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_05:51:30.349 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:00:01.425 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:00:01.437 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:06:00.326 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:06:00.338 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:06:29.302 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:06:29.315 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:20:00.258 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:20:00.276 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:20:00.358 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:20:00.371 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.60:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:28:43.735 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=2&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.10:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:28:43.761 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.10:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_06:59:30.254 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:00:06.678 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.10:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:04:00.237 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:04:04.082 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.10:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:18:00.219 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:18:01.909 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.10:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:39:30.207 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.19:93?l=SRC&d=src&i=1&t=aaudio\"\n"
"06-21-2023_07:39:31.617 2001 indi Routers#0.AxiaAudioRouter#1.AxiaAudioDestination#[tcp://10.91.7.54:93?l=DST&d=dst&i=1&t=aaudio] CurrentSourcePath=\"tcp://10.91.7.10:93?l=SRC&d=src&i=1&t=aaudio\"")
subst = "$1 - $2 - $3 - $4 - $5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.