import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/)?(?:www\\.)?facebook\\.com\\/(?:(?:\\w)*#!\\/)?(?:pages\\/)?(?:[\\w\\-]*\\/)*?(?:profile.php\\?id=(?=\\d.*))?([\\w\\-]*)?(?:[\\w\\-\\.]*)?";
final String string = "https://facebook.com/vietphu.nguyen.7?rc=p&refid=52&__tn__=R\n"
+ "https://facebook.com/shunchina?rc=p&refid=52&__tn__=R\n"
+ "https://facebook.com/phuocnguyen.nguyen.16568?rc=p&refid=52&__tn__=R\n"
+ "https://facebook.com/profile.php?id=100004404017311&rc=p&refid=52&__tn__=R";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}