$re = '/^(?!.*?\.{2,})[a-z0-9_\.]{2,32}$/m';
$str = 'n0de
invalid..username
capsareNOTallowedtoo
veryverylongnamearealsonotallowed
.owo.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);