import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?\\.{2,})[a-z0-9_\\.]{2,32}$";
final String string = "n0de\n"
+ "invalid..username\n"
+ "capsareNOTallowedtoo\n"
+ "veryverylongnamearealsonotallowed\n"
+ ".owo.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}