// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[[^\/]+(.+)\/[3-9]\d\d\-").unwrap();
let string = "/item/708-furfural-chemical-building-block
/item/645-furfural-derivatives-in-apple-cider-and-win";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}