$re = '/[[^\/]+(.+)\/[3-9]\d\d\-/m';
$str = '/item/708-furfural-chemical-building-block
/item/645-furfural-derivatives-in-apple-cider-and-win';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);