re = /[\w-]+\.txt:route-policy STATIC_TO_BGP|[\w-]+\.txt-end-policy/
str = 'RMAGSPO-SAUT01-01.txt:route-policy STATIC_TO_BGP
RMAGSPO-SAUT01-01.txt- if tag eq 40002 then
RMAGSPO-SAUT01-01.txt- set community (26615:1000, 26615:51100, 26615:30000, 26615:1401, 26615:8012, 65402:9003, 65402:40002)
RMAGSPO-SAUT01-01.txt- set origin igp
RMAGSPO-SAUT01-01.txt- endif
RMAGSPO-SAUT01-01.txt-end-policy
RMAGSPO-SAUT01-01.txt-!
RMAGSPO-SAUT01-01.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGSPO-SAUT01-01.txt- if tag eq 30210 then
--
RMAGSPO-SNE01-01.txt:route-policy STATIC_TO_BGP
RMAGSPO-SNE01-01.txt- if tag eq 40002 then
RMAGSPO-SNE01-01.txt- set community (26615:1000, 26615:51100, 26615:30000, 26615:1401, 26615:8012, 65402:9008, 65402:40002)
RMAGSPO-SNE01-01.txt- set origin igp
RMAGSPO-SNE01-01.txt- elseif tag eq 402 then
RMAGSPO-SNE01-01.txt- set community (26615:1000, 26615:51100, 26615:30000, 26615:1301, 26615:8011, 65402:9008, 65402:40002)
RMAGSPO-SNE01-01.txt- set origin igp
RMAGSPO-SNE01-01.txt- endif
RMAGSPO-SNE01-01.txt-end-policy
--
RMAGSPO-SPLJ05-01.txt:route-policy STATIC_TO_BGP
RMAGSPO-SPLJ05-01.txt- if tag eq 40002 then
RMAGSPO-SPLJ05-01.txt- set community (26615:1000, 26615:51100, 26615:1301, 26615:8011, 65402:9006, 65402:40002, 26615:30000)
RMAGSPO-SPLJ05-01.txt- set origin igp
RMAGSPO-SPLJ05-01.txt- endif
RMAGSPO-SPLJ05-01.txt-end-policy
RMAGSPO-SPLJ05-01.txt-!
RMAGSPO-SPLJ05-01.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGSPO-SPLJ05-01.txt- if tag eq 30210 then
--
RMAGSPO-SPVC03-01.txt:route-policy STATIC_TO_BGP
RMAGSPO-SPVC03-01.txt- if tag eq 40002 then
RMAGSPO-SPVC03-01.txt- set community (26615:1000, 26615:1401, 26615:51100, 26615:8012, 65402:9005, 65402:40002, 26615:30000)
RMAGSPO-SPVC03-01.txt- set origin igp
RMAGSPO-SPVC03-01.txt- elseif tag eq 40003 then
RMAGSPO-SPVC03-01.txt- set community (26615:1000, 26615:1301, 26615:51100, 26615:8011, 65402:9005, 65402:40002, 26615:30000)
RMAGSPO-SPVC03-01.txt- set origin igp
RMAGSPO-SPVC03-01.txt- endif
RMAGSPO-SPVC03-01.txt-end-policy
--
RMAGSPO-SPVF06-01.txt:route-policy STATIC_TO_BGP
RMAGSPO-SPVF06-01.txt- if tag eq 40002 then
RMAGSPO-SPVF06-01.txt- set community (26615:1000, 26615:30000, 26615:51100, 26615:1301, 26615:8011, 65402:9004, 65402:40002)
RMAGSPO-SPVF06-01.txt- set origin igp
RMAGSPO-SPVF06-01.txt- endif
RMAGSPO-SPVF06-01.txt-end-policy
RMAGSPO-SPVF06-01.txt-!
RMAGSPO-SPVF06-01.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP
RMAGSPO-SPVF06-01.txt- if tag eq 30210 then
--
RMDISPO-MSO01-01.txt:route-policy STATIC_TO_BGP
RMDISPO-MSO01-01.txt- if tag eq 40002 then
RMDISPO-MSO01-01.txt- set community (26615:1000, 26615:51100, 26615:1401, 26615:8012, 65402:9002, 65402:40002, 26615:30000)
RMDISPO-MSO01-01.txt- set origin igp
RMDISPO-MSO01-01.txt- endif
RMDISPO-MSO01-01.txt-end-policy
RMDISPO-MSO01-01.txt-!
RMDISPO-MSO01-01.txt-route-policy RMS-IN-FTTS-IPV4
RMDISPO-MSO01-01.txt- pass
--
RTBARJO0202.txt:route-policy STATIC_TO_BGP
RTBARJO0202.txt- if tag eq 51000 then
RTBARJO0202.txt- set community (26615:51000, 26615:8021, 26615:9070, 26615:1201, 26615:30000)
RTBARJO0202.txt- set origin igp
RTBARJO0202.txt- endif
RTBARJO0202.txt-end-policy
RTBARJO0202.txt-!
RTBARJO0202.txt-route-policy voip_migrados
RTBARJO0202.txt- if destination in prefix_voip_migrados then
--
RTBARJO0202.txt:route-policy STATIC_TO_BGP_IPV6
RTBARJO0202.txt- if tag eq 1000 then
RTBARJO0202.txt- set community (26615:8021, 26615:9070, 26615:1000)
RTBARJO0202.txt- set origin igp
RTBARJO0202.txt- elseif tag eq 41000 then
RTBARJO0202.txt- set community (26615:8021, 26615:9070, 26615:1201, 26615:51000, 26615:30000)
RTBARJO0202.txt- set origin igp
RTBARJO0202.txt- endif
RTBARJO0202.txt-end-policy
--
RTBASPO0302.txt:route-policy STATIC_TO_BGP
RTBASPO0302.txt- if tag eq 41000 then
RTBASPO0302.txt- set community (26615:41000, 26615:8012, 26615:9087, 26615:51000, 26615:1401, 26615:30000)
RTBASPO0302.txt- set origin igp
RTBASPO0302.txt- endif
RTBASPO0302.txt-end-policy
RTBASPO0302.txt-!
RTBASPO0302.txt-route-policy voip_migrados
RTBASPO0302.txt- if destination in prefix_voip_migrados then
--
RTBASPO0302.txt:route-policy STATIC_TO_BGP_IPV6
RTBASPO0302.txt- if tag eq 1000 then
RTBASPO0302.txt- set community (26615:8012, 26615:9087, 26615:1401, 26615:51000, 26615:30000)
RTBASPO0302.txt- set origin igp
RTBASPO0302.txt- endif
RTBASPO0302.txt-end-policy
RTBASPO0302.txt-!
RTBASPO0302.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP
RTBASPO0302.txt- if tag eq 30210 then
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end