# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w-]+\.txt:route-policy STATIC_TO_BGP|[\w-]+\.txt-end-policy"
test_str = ("RMAGSPO-SAUT01-01.txt:route-policy STATIC_TO_BGP\n"
"RMAGSPO-SAUT01-01.txt- if tag eq 40002 then\n"
"RMAGSPO-SAUT01-01.txt- set community (26615:1000, 26615:51100, 26615:30000, 26615:1401, 26615:8012, 65402:9003, 65402:40002)\n"
"RMAGSPO-SAUT01-01.txt- set origin igp\n"
"RMAGSPO-SAUT01-01.txt- endif\n"
"RMAGSPO-SAUT01-01.txt-end-policy\n"
"RMAGSPO-SAUT01-01.txt-!\n"
"RMAGSPO-SAUT01-01.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
"RMAGSPO-SAUT01-01.txt- if tag eq 30210 then\n"
"--\n"
"RMAGSPO-SNE01-01.txt:route-policy STATIC_TO_BGP\n"
"RMAGSPO-SNE01-01.txt- if tag eq 40002 then\n"
"RMAGSPO-SNE01-01.txt- set community (26615:1000, 26615:51100, 26615:30000, 26615:1401, 26615:8012, 65402:9008, 65402:40002)\n"
"RMAGSPO-SNE01-01.txt- set origin igp\n"
"RMAGSPO-SNE01-01.txt- elseif tag eq 402 then\n"
"RMAGSPO-SNE01-01.txt- set community (26615:1000, 26615:51100, 26615:30000, 26615:1301, 26615:8011, 65402:9008, 65402:40002)\n"
"RMAGSPO-SNE01-01.txt- set origin igp\n"
"RMAGSPO-SNE01-01.txt- endif\n"
"RMAGSPO-SNE01-01.txt-end-policy\n"
"--\n"
"RMAGSPO-SPLJ05-01.txt:route-policy STATIC_TO_BGP\n"
"RMAGSPO-SPLJ05-01.txt- if tag eq 40002 then\n"
"RMAGSPO-SPLJ05-01.txt- set community (26615:1000, 26615:51100, 26615:1301, 26615:8011, 65402:9006, 65402:40002, 26615:30000)\n"
"RMAGSPO-SPLJ05-01.txt- set origin igp\n"
"RMAGSPO-SPLJ05-01.txt- endif\n"
"RMAGSPO-SPLJ05-01.txt-end-policy\n"
"RMAGSPO-SPLJ05-01.txt-!\n"
"RMAGSPO-SPLJ05-01.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
"RMAGSPO-SPLJ05-01.txt- if tag eq 30210 then\n"
"--\n"
"RMAGSPO-SPVC03-01.txt:route-policy STATIC_TO_BGP\n"
"RMAGSPO-SPVC03-01.txt- if tag eq 40002 then\n"
"RMAGSPO-SPVC03-01.txt- set community (26615:1000, 26615:1401, 26615:51100, 26615:8012, 65402:9005, 65402:40002, 26615:30000)\n"
"RMAGSPO-SPVC03-01.txt- set origin igp\n"
"RMAGSPO-SPVC03-01.txt- elseif tag eq 40003 then\n"
"RMAGSPO-SPVC03-01.txt- set community (26615:1000, 26615:1301, 26615:51100, 26615:8011, 65402:9005, 65402:40002, 26615:30000)\n"
"RMAGSPO-SPVC03-01.txt- set origin igp\n"
"RMAGSPO-SPVC03-01.txt- endif\n"
"RMAGSPO-SPVC03-01.txt-end-policy\n"
"--\n"
"RMAGSPO-SPVF06-01.txt:route-policy STATIC_TO_BGP\n"
"RMAGSPO-SPVF06-01.txt- if tag eq 40002 then\n"
"RMAGSPO-SPVF06-01.txt- set community (26615:1000, 26615:30000, 26615:51100, 26615:1301, 26615:8011, 65402:9004, 65402:40002)\n"
"RMAGSPO-SPVF06-01.txt- set origin igp\n"
"RMAGSPO-SPVF06-01.txt- endif\n"
"RMAGSPO-SPVF06-01.txt-end-policy\n"
"RMAGSPO-SPVF06-01.txt-!\n"
"RMAGSPO-SPVF06-01.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
"RMAGSPO-SPVF06-01.txt- if tag eq 30210 then\n"
"--\n"
"RMDISPO-MSO01-01.txt:route-policy STATIC_TO_BGP\n"
"RMDISPO-MSO01-01.txt- if tag eq 40002 then\n"
"RMDISPO-MSO01-01.txt- set community (26615:1000, 26615:51100, 26615:1401, 26615:8012, 65402:9002, 65402:40002, 26615:30000)\n"
"RMDISPO-MSO01-01.txt- set origin igp\n"
"RMDISPO-MSO01-01.txt- endif\n"
"RMDISPO-MSO01-01.txt-end-policy\n"
"RMDISPO-MSO01-01.txt-!\n"
"RMDISPO-MSO01-01.txt-route-policy RMS-IN-FTTS-IPV4\n"
"RMDISPO-MSO01-01.txt- pass\n"
"--\n"
"RTBARJO0202.txt:route-policy STATIC_TO_BGP\n"
"RTBARJO0202.txt- if tag eq 51000 then\n"
"RTBARJO0202.txt- set community (26615:51000, 26615:8021, 26615:9070, 26615:1201, 26615:30000)\n"
"RTBARJO0202.txt- set origin igp\n"
"RTBARJO0202.txt- endif\n"
"RTBARJO0202.txt-end-policy\n"
"RTBARJO0202.txt-!\n"
"RTBARJO0202.txt-route-policy voip_migrados\n"
"RTBARJO0202.txt- if destination in prefix_voip_migrados then\n"
"--\n"
"RTBARJO0202.txt:route-policy STATIC_TO_BGP_IPV6\n"
"RTBARJO0202.txt- if tag eq 1000 then\n"
"RTBARJO0202.txt- set community (26615:8021, 26615:9070, 26615:1000)\n"
"RTBARJO0202.txt- set origin igp\n"
"RTBARJO0202.txt- elseif tag eq 41000 then\n"
"RTBARJO0202.txt- set community (26615:8021, 26615:9070, 26615:1201, 26615:51000, 26615:30000)\n"
"RTBARJO0202.txt- set origin igp\n"
"RTBARJO0202.txt- endif\n"
"RTBARJO0202.txt-end-policy\n"
"--\n"
"RTBASPO0302.txt:route-policy STATIC_TO_BGP\n"
"RTBASPO0302.txt- if tag eq 41000 then\n"
"RTBASPO0302.txt- set community (26615:41000, 26615:8012, 26615:9087, 26615:51000, 26615:1401, 26615:30000)\n"
"RTBASPO0302.txt- set origin igp\n"
"RTBASPO0302.txt- endif\n"
"RTBASPO0302.txt-end-policy\n"
"RTBASPO0302.txt-!\n"
"RTBASPO0302.txt-route-policy voip_migrados\n"
"RTBASPO0302.txt- if destination in prefix_voip_migrados then\n"
"--\n"
"RTBASPO0302.txt:route-policy STATIC_TO_BGP_IPV6\n"
"RTBASPO0302.txt- if tag eq 1000 then\n"
"RTBASPO0302.txt- set community (26615:8012, 26615:9087, 26615:1401, 26615:51000, 26615:30000)\n"
"RTBASPO0302.txt- set origin igp\n"
"RTBASPO0302.txt- endif\n"
"RTBASPO0302.txt-end-policy\n"
"RTBASPO0302.txt-!\n"
"RTBASPO0302.txt-route-policy GERENCIA_UBB_STATIC_TO_BGP\n"
"RTBASPO0302.txt- if tag eq 30210 then\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.