$re = '/([A-Z][a-z]{1,}) ([A-Z][a-z]{1,})/';
$str = 'ivan ivanov
Ivan Ivanov
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);