import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\#)\\d*";
final String string = "[1518-11-01 00:00] Guard #10 begins shift\n"
+ "[1518-11-01 00:05] falls asleep\n"
+ "[1518-11-01 00:25] wakes up\n"
+ "[1518-11-01 00:30] falls asleep\n"
+ "[1518-11-01 00:55] wakes up\n"
+ "[1518-11-01 23:58] Guard #99 begins shift\n"
+ "[1518-11-02 00:40] falls asleep\n"
+ "[1518-11-02 00:50] wakes up\n"
+ "[1518-11-03 00:05] Guard #10 begins shift\n"
+ "[1518-11-03 00:24] falls asleep\n"
+ "[1518-11-03 00:29] wakes up\n"
+ "[1518-11-04 00:02] Guard #99 begins shift\n"
+ "[1518-11-04 00:36] falls asleep\n"
+ "[1518-11-04 00:46] wakes up\n"
+ "[1518-11-05 00:03] Guard #99 begins shift\n"
+ "[1518-11-05 00:45] falls asleep\n"
+ "[1518-11-05 00:55] wakes up\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}