// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$").unwrap();
let string = "Manifest.MoM.tar
Manifest-random-pack
Manifest.full
latest
latest_version
latest.sig
latest_version.sig
first
first.sig
10-20-randomnumber
randomnumber.tar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}