import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:Manifest.*|.*\\.[sS][iI][gG]|.*\\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$";
final String string = "Manifest.MoM.tar\n"
+ "Manifest-random-pack\n"
+ "Manifest.full\n"
+ "latest\n"
+ "latest_version\n"
+ "latest.sig\n"
+ "latest_version.sig\n"
+ "first\n"
+ "first.sig\n"
+ "10-20-randomnumber\n"
+ "randomnumber.tar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}