using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$";
string input = @"Manifest.MoM.tar
Manifest-random-pack
Manifest.full
latest
latest_version
latest.sig
latest_version.sig
first
first.sig
10-20-randomnumber
randomnumber.tar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}