#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$"
Local $sString = "Manifest.MoM.tar" & @CRLF & _
"Manifest-random-pack" & @CRLF & _
"Manifest.full" & @CRLF & _
"latest" & @CRLF & _
"latest_version" & @CRLF & _
"latest.sig" & @CRLF & _
"latest_version.sig" & @CRLF & _
"first" & @CRLF & _
"first.sig" & @CRLF & _
"10-20-randomnumber" & @CRLF & _
"randomnumber.tar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")