$re = '/^[\w-]+@([\w-]+\.)+[\w-]{2,4}$/';
$str = 'test@test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);