package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<.*>)(.*)(<.*>)(.*)`)
var str = ` <html>
<head>
<title>Sample site</title>
</head>
<body>
<div>text<div>more text</div>and more...</div>in body
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}