use strict;
my $str = '<::after>
<!--::after-->
<div class="page-text-tmp">
<h2 dir="ltr">Габро — що за камінь?</h2>
<p dir="ltr">Габро-діабаз відноситься до вулканічним гірським породам. Він знайшов широке поширення в сфері будівництва та архітектурного декорування. За своїми експлуатаційними характеристиками він нагадує граніт. Найчастіше камінь використовують для створення архітектурних елементів та виготовлення бруківки. Вироби з габро високо цінуються серед фахівців, тому й ціна у них відповідна.</p>
<p dir="ltr">Наша компанія поставляє натуральний камінь <a href="/ua">граніт</a> з різних країн світу. Габро-діабаз видобувають в Україні, Австралії і Карелії. Викопне з вітчизняних родовищ сьогодні користується особливою популярністю. Це зумовлено його високою механічною міцністю і простотою обробки. Завдяки цьому, з габро повсюдно виробляють плитку, сходи, сходи, бордюри і багато іншого. Купити будь-які з перерахованих виробів можна у нас. Ми гарантуємо вигідні умови співпраці та приємний сервіс.</p>
<h2 dir="ltr">Якими перевагами володіє граніт габро?</h2>
<p dir="ltr">Якщо ви вирішили придбати габро, граніт, зверніть увагу на каталог нашої компанії. Ми самостійно здійснюємо кінцеву обробку гірської породи і використовуємо сучасне високотехнологічне обладнання. У нашому асортименті представлені не тільки слеби, але і готові вироби з габро. Особливою популярністю серед клієнтів користується бруківка. Вона володіє тривалим терміном експлуатації і чудовим зовнішнім виглядом. Вся без винятку продукція з даного каменю має масу переваг. Серед них можна виділити:</p>
<ul dir="ltr">
<li><::before>
<!--::before-->високі міцнісні характеристики;</li>
<li><::before>
<!--::before-->стійкість до впливу несприятливих кліматичних умов;</li>
<li><::before>
<!--::before-->здатність тривалий час зберігати якісне полірування;</li>
<li><::before>
<!--::before-->екологічна чистота і безпека;</li>
<li><::before>
<!--::before-->податливість до обробки;</li>
<li><::before>
<!--::before-->зносостійкість і довговічність.</li>
</ul>
<p dir="ltr">Рекомендуємо звернути увагу на <a href="https://mramor-granit.com/ua/ukraine-granit">українська граніт</a> габро Коростишів — камінь з вітчизняного родовища. Він відрізняється оригінальною текстурою і насиченим кольором. Сляби з цього копалин можна замовити оптом на вигідних умовах.</p>
<h2 dir="ltr">Граніт габро — родовище якої країни віддати перевагу? </h2>
<p dir="ltr">Видобуток граніту габро ведеться в декількох точках по всьому світу. Це Україна, Австралія і Карелія. В залежності від родовища, камінь може відрізнятися по текстурі і кольору. Найбільш якісним і естетичним вважається граніт габро Карелія. Він відрізняється повністю чорним кольором без будь-яких вкраплень і високими показниками морозостійкості. Матеріал досить міцний і зносостійкий, тому відмінно підходить для зовнішніх оздоблювальних робіт. Граніт габро Букинский — вітчизняний камінь, який видобувають в Житомирській області. Його головна перевага — більш демократична вартість. Що стосується, фізико-механічних та експлуатаційних властивостей, то він мало в чому поступається своєму закордонному побратимові. Якщо ви хочете замовити габро або <a href="https://mramor-granit.com/ua/anastasia-red">анастасіївський граніт</a> від виробника «Металлстоун», тоді дзвоніть нам. Вся необхідна контактна інформація розташована у відповідному розділі сайту.</p>
</div>';
my $regex = qr/<a\shref=.*?<\/a>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}