# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?:\/\/[^\/]+(\/d\/|\/m\/)"
test_str = ("https://internet.hughesnet.com/d/order/?exp=1\n"
"https://test-internet.hughesnet.redventures.com/d/order/?exp=1\n"
"http://localhost-internet.hughesnet.redventures.com/d/order/?exp=1\n\n"
"https://internet.hughesnet.com/mobile/order/?exp=1\n"
"https://test-internet.hughesnet.redventures.com/mobile/order/?exp=1\n"
"http://localhost-internet.hughesnet.redventures.com/mobile/order/?exp=1\n\n"
"https://internet.hughesnet.com/m/order/?exp=1\n"
"https://test-internet.hughesnet.redventures.com/m/order/?exp=1\n"
"http://localhost-internet.hughesnet.redventures.com/m/order/?exp=1\n\n"
"https://internet.hughesnet.com/order/?exp=1\n"
"https://test-internet.hughesnet.redventures.com/order/?exp=1\n"
"http://localhost-internet.hughesnet.redventures.com/order/?exp=1\n\n"
"https://internet.hughesnet.com/?exp=1\n"
"https://test-internet.hughesnet.redventures.com/?exp=1\n"
"http://localhost-internet.hughesnet.redventures.com/?exp=1\n\n"
"https://www.directvdeals.com/d/bundles.html\n\n\n\n"
"https://www.directvdeals.com/d/?hnkw=%2Bhughesnet&s_ace=&s_adp=1t1&s_agid=39321230140&s_aid=221800323027&s_cid=739574798&s_dvc=c&s_kid=22337170519&s_loci=&s_locp=9010670&s_ntwk=g&s_pid=1&s_plid=&s_sid=197&s_tgtid=aud-329726877564:kwd-22337170519&utm_mcid=3198048&utm_source=google&utm_medium=cpc&utm_term=%2Bhughesnet&utm_cmpid=739574798&utm_adgid=39321230140&utm_tgtid=aud-329726877564:kwd-22337170519&utm_mt=b&utm_adid=221800323027&utm_dvc=c&utm_ntwk=g&utm_adpos=1t1&utm_plcmnt=&utm_locphysid=9010670&utm_locintid=&utm_feeditemid=&utm_devicemdl=&utm_plcmnttgt=&gclid=CjwKCAjw36DpBRAYEiwAmVVDMMUJoi-t1iWDby7eC5zV3HqMA4RM9iIDsihOnFwTNw9P2seGKtSfoRoCuTMQAvD_BwE")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.