import Foundation
let pattern = #"^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\/(?:3[0-2]|[12]*\d)){0,1}[,|-])*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\/(?:3[0-2]|[12]*\d)){0,1}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
192.168.1.1,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24
192.168.1.1/32
192.168.1.1
192.168.1.1/32
192.168.1.1/12
192.168.1.1/24
192.168.1.1/24
192.168.1.1/0,192.168.1.1/0
10.0.0.0/24
172.16.0.1-172.16.0.255
192.168.1.1,10.0.0.1/24,172.16.0.1-172.16.0.10
64.33.232.212
64.33.232.210/24
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)