re = /((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)/m
str = '**part strong,** *part emphasized*'
subst = '<em>\\g<common>\\g<uncommon></em>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result