$re = '/((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)/m';
$str = '**part strong,** *part emphasized*';
$subst = "<em>\g<common>\g<uncommon></em>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;