const regex = new RegExp('((?<=\\s)\\*(?P<common>[^\\*]+?)\\*(?=\\s)|^\\*(?P<uncommon>[^\\*].*[^\\*])\\*$)', 'gm')
const str = `**part strong,** *part emphasized*`;
const subst = `<em>\g<common>\g<uncommon></em>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);