using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)";
string substitution = @"<em>\g<common>\g<uncommon></em>";
string input = @"**part strong,** *part emphasized*";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}