$re = '/^(?!(dist[\/]?((.*)?[\/]?\b)))/m';
$str = 'test/dist/
test/sdfsdf/
dsfsdfsdfs
sdfsdfsdf/
dist/sdfsdf
dist/tes
dist/dsdfsdf
sdfsdf
sdfsdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);