using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(dist[\/]?((.*)?[\/]?\b)))";
string input = @"test/dist/
test/sdfsdf/
dsfsdfsdfs
sdfsdfsdf/
dist/sdfsdf
dist/tes
dist/dsdfsdf
sdfsdf
sdfsdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}