import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!666|000)(?!219-09-9999|078-05-1120)[0-8]\\d{2}-\\d[1-9]-(?!0{4})\\d{3}[1-9]$";
final String string = "242-35-4646\n"
+ "242-10-1111\n"
+ "242-35-4640\n"
+ "666-35-4646\n"
+ "000-35-3939\n"
+ "242-35-0000\n"
+ "901-35-2828\n"
+ "343-45-6829\n"
+ "078-05-1120\n"
+ "219-09-9999\n"
+ "323-71-3076\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}