using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)\((\?<(?<name>[\w][\w\d_]+)>|(?=[^\?]))";
string input = @"(?:(?<=s+)(?<template>Td{1,2})s+|(?<=\()(?<ptemplate>Td{1,2})|(?:\b(?<value>v\d{1,2})\b(.*)))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}