#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\\)\((\?<(?<name>[\w][\w\d_]+)>|(?=[^\?]))"
Local $sString = "(?:(?<=s+)(?<template>Td{1,2})s+|(?<=\()(?<ptemplate>Td{1,2})|(?:\b(?<value>v\d{1,2})\b(.*)))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")