$re = '/[#]+\d/';
$str = 'results.1_#1mytest_test.=fail, more info';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);