using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[#]+\d";
string input = @"results.1_#1mytest_test.=fail, more info";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}