re = /^(?<dir1>(\w(-)*)+)\.(?<dir2>(\w(-)*)+)\.(?<dir3>(\w(-)*)+)\.dv$/m
str = 'mine.okoaloans.app-1.dv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end