package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<dir1>(\w(-)*)+)\.(?<dir2>(\w(-)*)+)\.(?<dir3>(\w(-)*)+)\.dv$`)
var str = `mine.okoaloans.app-1.dv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}