using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<dir1>(\w(-)*)+)\.(?<dir2>(\w(-)*)+)\.(?<dir3>(\w(-)*)+)\.dv$";
string input = @"mine.okoaloans.app-1.dv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}