$re = '/(<(\w+)(?:\/|.*?)>)((\w+\s?)+)(<(?:\/|)\2+>)/m';
$str = '\'<a class="class">\' . $variable . \'</a>\'
"<a class="class">" . $variable . "</a>"
<a class="class">{{ $variable }}</a>
<a class="class">{{ __("words") }}</a>
<a class="class">some words</a>
<a/>some words<a>
<a/>some words</a>
<a/></a>
<a>Some words</a>
<a><a>Some words</a></a>';
$subst = "$1{{ __(\"$3\") }}$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;