#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<(\w+)(?:\/|.*?)>)((\w+\s?)+)(<(?:\/|)\2+>)"
Local $sString = "'<a class="class">' . $variable . '</a>'" & @CRLF & _
""<a class="class">" . $variable . "</a>"" & @CRLF & _
"<a class="class">{{ $variable }}</a>" & @CRLF & _
"<a class="class">{{ __("words") }}</a>" & @CRLF & _
"" & @CRLF & _
"<a class="class">some words</a>" & @CRLF & _
"<a/>some words<a>" & @CRLF & _
"<a/>some words</a>" & @CRLF & _
"<a/></a>" & @CRLF & _
"<a>Some words</a>" & @CRLF & _
"<a><a>Some words</a></a>"
Local $sSubst = "$1{{ __("$3") }}$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)