re = /^https:\/\/w{3}(.youtube.com)\/(watch\?|playlist\?)(v=\w*-?\w*&list=\w*)|(v=\w*-?\w*)|(list=\w*-?\w*)/m
str = 'https://www.youtube.com/watch?v=ba-HMvDn_vU&list=PLUl4u3cNGP60IKRN_pFptIBxeiMc0MCJP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end