const regex = /^https:\/\/w{3}(.youtube.com)\/(watch\?|playlist\?)(v=\w*-?\w*&list=\w*)|(v=\w*-?\w*)|(list=\w*-?\w*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/w{3}(.youtube.com)\\\/(watch\\?|playlist\\?)(v=\\w*-?\\w*&list=\\w*)|(v=\\w*-?\\w*)|(list=\\w*-?\\w*)', 'gm')
const str = `https://www.youtube.com/watch?v=ba-HMvDn_vU&list=PLUl4u3cNGP60IKRN_pFptIBxeiMc0MCJP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}