re = /\b(?:\d+)?[24680]\b/m
str = '1 12 23 34 45 56 67 78 89 90 21 13 24 35 46 57 68 79 80 123 234 345 456 567 678 789 890 2 4 6 8 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end