using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:\d+)?[24680]\b";
string input = @"1 12 23 34 45 56 67 78 89 90 21 13 24 35 46 57 68 79 80 123 234 345 456 567 678 789 890 2 4 6 8 0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}