using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!array\(\n *)array\(\n* *(.*)\)([,;])*";
string substitution = @"[$1]$2";
string input = @"case 'current_operations':
$array = array(
array('stage_of_development', $this->AB->getTextRep('devstage')),
array('employees', $this->AB->getCompanyProp('employeesnumber')),
array('profitability', $this->AB->getTextRep('profitability'))
);
$icon = 'icon-aim';
break;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}