const regex = new RegExp('\\b((0?[1-9]|[12][0-9]|3[01])[-/.\\s](0?[1-9]|1[0-2])[-/.\\s](19[0-9]{2}|200[0-9]))|((0?[1-9]|1[0-2])[-/.\\s](0?[1-9]|[12][0-9]|3[01])[-/.\\s](19[0-9]{2}|200[0-9]))|(([012][1-9]|3[01])(st|nd|rd|th)?\\s(?i:Jan|Feb|Fév|Mar|Apr|Avr|May|Mai|Jun|Juin|Jul|Juil|Aug|Sep|Sept|Oct|Nov|Dec|Déc)\\s(?:19[0-9]{2}|200[0-9]))|((?i:Jan|Feb|Fév|Mar|Apr|Avr|May|Mai|Jun|Juin|Jul|Juil|Aug|Sep|Sept|Oct|Nov|Dec|Déc)\\s(?:0?[1-9]|[12][0-9]|3[01])(st|nd|rd|th)?\\s(?:19[0-9]{2}|200[0-9]))|((0?[1-9]|[12][0-9]|3[01])(st|nd|rd|th)?\\s(?i:January|janvier|February|fevrier|février|March|mars|April|avril|May|mai|June|juin|July|juillet|August|aout|août|September|septembre|October|octobre|November|novembre|December|décembre|decembre)\\s(?:19[0-9]{2}|200[0-9]))|((?iu:January|janvier|February|fevrier|février|March|mars|April|avril|May|mai|June|juin|July|juillet|August|aout|août|September|septembre|October|octobre|November|novembre|December|décembre|decembre)\\s(?:0?[1-9]|[12][0-9]|3[01])(st|nd|rd|th)?\\s(?:19[0-9]{2}|200[0-9]))|(0?[1-9]|1[0-2])[-\\/.\\s](0?[1-9]|[12][0-9]|3[01])[-\\/.\\s](19|20)0[0-9]|(19|20)0[0-9][-\\/.\\s](0?[1-9]|1[0-2])[-\\/.\\s](0?[1-9]|[12][0-9]|3[01])\\b
', 'gm')
const str = `April 2nd 2008
April 2 2008
April 02 2008
2009-01-01
31-03-2009
03-31-2009
31 March 2009
March 31 2009
31 mars 2009
May 10th 1989
April 2nd 2008
2009.01.01
2009 1 31
31st december 2009
31 décembre 2009
31 Decembre 2009
2009/02/01
2009.01.01
2009 01 01
31 03 2009
12 31 2009`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}