import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((0?[1-9]|[12][0-9]|3[01])[-/.\\s](0?[1-9]|1[0-2])[-/.\\s](19[0-9]{2}|200[0-9]))|((0?[1-9]|1[0-2])[-/.\\s](0?[1-9]|[12][0-9]|3[01])[-/.\\s](19[0-9]{2}|200[0-9]))|(([012][1-9]|3[01])(st|nd|rd|th)?\\s(?i:Jan|Feb|Fév|Mar|Apr|Avr|May|Mai|Jun|Juin|Jul|Juil|Aug|Sep|Sept|Oct|Nov|Dec|Déc)\\s(?:19[0-9]{2}|200[0-9]))|((?i:Jan|Feb|Fév|Mar|Apr|Avr|May|Mai|Jun|Juin|Jul|Juil|Aug|Sep|Sept|Oct|Nov|Dec|Déc)\\s(?:0?[1-9]|[12][0-9]|3[01])(st|nd|rd|th)?\\s(?:19[0-9]{2}|200[0-9]))|((0?[1-9]|[12][0-9]|3[01])(st|nd|rd|th)?\\s(?i:January|janvier|February|fevrier|février|March|mars|April|avril|May|mai|June|juin|July|juillet|August|aout|août|September|septembre|October|octobre|November|novembre|December|décembre|decembre)\\s(?:19[0-9]{2}|200[0-9]))|((?iu:January|janvier|February|fevrier|février|March|mars|April|avril|May|mai|June|juin|July|juillet|August|aout|août|September|septembre|October|octobre|November|novembre|December|décembre|decembre)\\s(?:0?[1-9]|[12][0-9]|3[01])(st|nd|rd|th)?\\s(?:19[0-9]{2}|200[0-9]))|(0?[1-9]|1[0-2])[-\\/.\\s](0?[1-9]|[12][0-9]|3[01])[-\\/.\\s](19|20)0[0-9]|(19|20)0[0-9][-\\/.\\s](0?[1-9]|1[0-2])[-\\/.\\s](0?[1-9]|[12][0-9]|3[01])\\b\n";
final String string = "April 2nd 2008\n"
+ "April 2 2008\n"
+ "April 02 2008\n"
+ "2009-01-01\n"
+ "31-03-2009\n"
+ "03-31-2009\n"
+ "31 March 2009\n"
+ "March 31 2009\n"
+ "31 mars 2009\n"
+ "May 10th 1989\n"
+ "April 2nd 2008\n"
+ "2009.01.01\n"
+ "2009 1 31\n"
+ "31st december 2009\n"
+ "31 décembre 2009\n"
+ "31 Decembre 2009\n"
+ "2009/02/01\n"
+ "2009.01.01\n"
+ "2009 01 01\n"
+ "31 03 2009\n"
+ "12 31 2009";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}